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I work on a Mac or Linux system. Small things may vary on a Windows 
computer! 

I. General 
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The Larus was developed by a project team led by Dr. Klaus Schäfer, Horst Rupp and 
Maximilian Betz developed and published open source (https://github.com/larus-breeze). I 
rebuilt the Larus and am summarizing my experiences here to help you easily implement 
the replication. The Larus is a non-commercial project and it may not be distributed 
commercially without the permission of the developers! 
Never connect a 12V power source AND a USB cable at the same time! The power 
supply may only be provided via one of the two options! 
 
The driver is currently only integrated into OpenSoar. As things stand today, you have to 
install OpenSoar instead of XCSoar on your device. 

 
 
 

II. Assembling the boards 
 
You can find all the files required to create the boards in Github. The chip U8 (NEO-M9N) 
can only be soldered on the Essential. But I basically had it soldered to all boards and cut 
the TX conductor track of the U8 (PIN 20) on the dual version. This means that it does not 
send to the U1 (STM32F407VGTx) but only the additional connection board required for 
the dual version. This has the advantage that you could always use the board for the 
Essential if you reconnect the severed conductor track and disconnect the connection board 
for the dual version. You should also note that only one of the two voltage converters U17 
(SK6013BS5-33) or U18 (SK6013AD4-33) may be soldered on! They are simply 
alternatives to each other! 

 
 
 

III. Programming 
 

STM32: 
1. Download the programmer from ST (https://www.st.com/en/development-

tools/stm32cubeprog.html). 
 

2. Install the program and start it. 
 

3. Select the USB connection type at the top right. 
 

4. Download the latest release of the program (sw_sensor.elf). (https://github.com/larus-
breeze/sw_sensor/releases). 
 

5. Press the PGM button on the Larus and, while keeping the button pressed, connect the 
Larus to the PC using the STM connector. 

 
6. Click on the Reload button next to Port and your USB connection will be displayed. 

 
7. Click Connect. 

 
8. Click on Open file and select the sw_sensor.elf file. 

 
9. Click on Download. 
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10. Once the download is complete you can exit the program. 

 
ESP32: 

1. It's best to clone sw_sensor completely onto your hard drive (https://github.com/larus-
breeze/sw_sensor/tree/master).   
 

2. To do this, either click on the green Code button at the top right and then click Download 
ZIP, or do it using the terminal with the git commands according to the information on 
the page. For the second option, you must have an account with a stored SSH key on 
GitHub. 

 
3. Install Arduino IDE. I'm working with version 1.8.19. With the current version 2, one 

or two things may look different. 
 

4. In Arduino IDE click on Arduino -> Settings. 
 

5. Add the URL under “Additional board manager URLs”. If URLs have already been 
entered, add additional URLs using commas and spaces.  
https://dl.espressif.com/dl/package_esp32_index.json 
 

6. Click Tools -> Board -> Board Manager and search for ESP32. 
 

7. Select and install “ESP32 by Espressif Systems”. 
 

8. You may still need to install the driver for the ESP's serial 
adapterhttps://sparks.gogo.co.nz/ch340.html 
 

9. Opens the sketch ESP32_sketch_BT_WLAN.ino.  
 

10. Arduino IDE will ask you if the file can be moved to a folder of the same name. 
Confirms this. 
 

11. The file is set so that the Larus can be connected via Bluetooth by default. If the 
connection is to be established with WiFi, BTMode false and WiFiMode true must be 
set. 

 
12. You can also change the name of your device by typing const char *ssid = "Larus"; in 

the line. enter your name instead of Larus. Be careful with special characters! 
 

13. To upload, set the following under Tools: 
 
- Board: ESP32 Wrover Module 
- Upload Speed: 921600 
- Flash Frequency: 80MHz 
- Flash Mode: QIQ 
- Partition Scheme: No OTA (2MB APP/2MB SPIFFS) 
- Core Debug Level: “Keine” 
- Erase All Flash Before Sketch Upload: “Disabled” 
- Port: See which one is added after connecting the ESP32 with the USB cable (for 

me cu.wchusbserial14200) 
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14. Upload sketch. 

 
GNSS Modul: 

1. Download the u-center program, not u-center 2, here and install it: 
https://www.u-blox.com/en/product/u-center 

 
2. Download the firmware for the connection board of the dual version:https://www.u-

blox.com/en/ubx-
viewer/view/UBX_F9_100_HPG_113_ZED_F9P.7e6e899c5597acddf2f5f2f70fdf5fbe
.bin?url=https%3A%2F%2Fwww.u-
blox.com%2Fsites%2Fdefault%2Ffiles%2FUBX_F9_100_HPG_113_ZED_F9P.7e6e
899c5597acddf2f5f2f70fdf5fbe.bin 

 
3. Use the configuration files from here: 

https://github.com/larus-breeze/sw_sensor/tree/master/configuration 
- Ardusimple_Heading_Baseboard_100ms.txt is for the large connection board of the 

dual version 
- Ardusimple_Heading_Huckepack_100ms.txt is for the small connection board of 

the dual versionuBlox_M9N_75ms.txt is for the chip U8 (NEO-M9N) of the 
Essential version 

 
Dual: 

1. Connect the micro USB port on the side opposite the small circuit board to the PC. 
 

 
 

2. Opens the u-center program. 
 

3. At the top left, the connection module should be green. If not, click on the small arrow 
next to it and select the correct COM port (the icon will then turn green). 
 

4. Furthermore, the connection symbol next to the COM port and the baud rate must flash 
green at the bottom of the footer to the right. 

 
5. If this is not the case, try different baud rates at the top right under the save symbol until 

the symbol flashes green. For me it was usually 38400, 115200 or 460800bps. 
 

6. Click on Tools, Firmware Update to perform a firmware update. 
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7. Select the following file under Firmware Image: 

UBX_F9_100_HPG_113_ZED_F9P.7e6e899c5597acddf2f5f2f70fdf5fbe.bin 
 

8. Select the setting options as shown in the figure. 

 
 
9. Click on the green Go at the bottom left. 

 
10. The update takes a while and ends with the info Exit code (0) and Go turns green again. 

 
11. Check again at the bottom of the footer whether the connection symbol is flashing green. 

If not, correct it. 
 

12. Click on Tools, Receiver Configuration to upload the configuration file. 
 

13. For Generation u-blox, select Generation 9. 
 

14. Select the file Ardusimple_Heading_Baseboard_100ms.txt and click on Transfer File -
> GNSS. 
 

15. The configuration file is not saved in the chip! You still have to do this separately. 
 

16. To do this, click on View -> Configuration View -> CFG (Configuration) and set the 
values as shown in the picture. 
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17. Then click on Send at the bottom left. 
 

18. Now the same thing has to be done with the small circuit board. 
 

19. Connect the micro USB port next to the small circuit board to the PC, and connect to 
the module with the new COM port. 
 

20. Check again at the bottom of the footer whether the connection symbol is flashing green. 
If not, correct it. 
 

21. Click Tools, Firmware Update again to perform another firmware update. 
 

22. Click on the green Go again at the bottom left and wait until the update is complete. 
 

23. Check again at the bottom of the footer whether the connection symbol is flashing green. 
If not, correct it. 
 

24. Click Tools, Receiver Configuration again to upload the configuration file. 
 
25. For Generation u-blox, select Generation 9. 

 
26. Select the file Ardusimple_Heading_Huckepack_100ms.txt and click on Transfer File 

-> GNSS. 
 

27. It will end with an error message because the baud rate changes during upload. 
 

28. Check again at the bottom of the footer whether the connection symbol is flashing green. 
If not, correct it. 

 
29. Click on Tools, Receiver Configuration again to upload the configuration file and this 

time it works without errors. 
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30. The configuration file is not saved in the chip here either! You still have to do this 
separately. 
 

31. To do this, click on View -> Configuration View -> CFG (Configuration) and set the 
values as shown in the picture above. 

 
32. Then click on Send at the bottom left. 

 
Essential or if additionally installed on Dual NEO-M9N: 

1. Connects the vertical USB-C port on the Larusbord to the PC. 
 

2. Opens the u-center program. 
 

3. At the top left, the connection module should be green. If not, click on the small arrow 
next to it and select the correct COM port (the icon will then turn green). 
 

4. Furthermore, the connection symbol next to the COM port and the baud rate must flash 
green at the bottom of the footer to the right. 
 

5. If this is not the case, try different baud rates at the top right under the save symbol until 
the symbol flashes green. For me it was usually 38400, 115200 or 460800bps. 
 

6. Click on Tools, Receiver Configuration to upload the configuration file. 
 

7. For Generation u-blox, select Generation 9. 
 

8. Select the file uBlox_M9N_75ms.txt and click on Transfer File -> GNSS. 
 

9. The configuration file is not saved in the chip here either! You still have to do this 
separately. 
 

10. To do this, click on View -> Configuration View -> CFG (Configuration) and set the 
values as shown in the picture above. 
 

11. Then click on Send at the bottom left. 
 
 
 

IV. Assembly 
 

1. Cut 8 M4 threads into the housing so that you can later attach the covers with M4x10 
brass screws. 
 

2. Mount the hose connections on your pneumatic block. 
 

3. Make sure that the thicker hose connections point outwards and the thin ones point 
inwards. 
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4. To be on the safe side, coat the threads with some sealant before assembly. 
 

5. Mount the tire block on the circuit board using the 6 M2 screws. 
 

6. If your tire block does not have a seal, coat the sealing surface with some sealant before 
assembly. 
 

7. Insert the circuit board into your housing and mount the cover with the cutouts for the 
pressure connections. 

 

 
 

8. On the Essential, the RJ45 socket rests slightly on the housing. You have to remove a 
corner in the case. Not too much, otherwise the M4 screw won't hold properly later. 
 

9. Connect the connections of the pneumatic block to the pressure sensor as shown in the 
illustration. 
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10. Install the cable for the WiFi/BT antenna and screw on the antenna. 
 

 
 

11. Installs the cable for the GPS antenna in the Essential. 
 

 
 

12. To connect the connection board for the dual version to the Larus board, you need an 
approximately 8cm long, 6-wire cable that has a JST GH 1.25mm connector on one side 
and a Molex connector 51021-0600 on the other side has. 
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13. You can see the occupancy in the photo. 
 

 
 

14. I couldn't buy a suitable cable, so I bought a cable with the JST GH connector and 
crimped the Molex connector on the other side myself. The contacts are extremely small 
and crimping is extremely difficult. 

 
15. Connect the cable for the connection board to the Larus board. 

 

 
 

16. Get a 1.5mm thick GRP plate measuring 74mm x 65mm. 
 
17. Drill three 3.5mm holes into this plate according to the drawing. 
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18. Screw the connection board onto the GRP plate using three M3x8 brass screws and 
brass nuts. 

 
19. I printed 1mm thick disks as spacers, which I placed between the connection board and 

the GRP plate for each of the 3 screws. 
 

20. Apply some epoxy resin to the threads to secure them. 
 

 
 

21. Shorten the screw under the small circuit board flush with the nut, otherwise it will not 
fit over the standing USB-C socket later. 
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22. Also remove the cap that may be on the standing USB-C socket. 
 

23. Screw the 15cm long SMA extension into the place marked GNSS1, and the 10cm long 
SMA extension into the place marked GNSS1 in the lid. 
 

24. Remove the small circuit board and screw on the 15cm long SMA extension. 
 

25. Screw the 10cm long SMA extension onto the connector on the motherboard. 
 

26. You may have to twist the angled plugs a little more so that they don't get in the way 
and don't rest unnecessarily. 
 

27. Slide the GRP plate with the connection board into the fourth rail from above so that 
the small circuit board is on the side with the pressure connections. 
 

 
 

28. Make sure that the cables for the WiFi/BT antenna and for connecting the adapter board 
run freely under the GRP plate and do not get caught. Otherwise they can be damaged. 
 

29. Attach the small circuit board and push the GRP plate until the SMA connector rests on 
the cover on the side with the pressure connections. 

 
30. Plug in the connector to the Larus board. 
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31. Bend the SMA cables so that they lie nicely. 
 

 
 

32. Slide the housing cover on and also screw the cover to the connections for the GPS 
antenna. 
 

33. Tests whether the SD card goes out and in easily. You may need to do some work on 
the slot with a key file 
 
 
 

V. Installation of the Larus 
 
- The Larus can be installed in any position and can be corrected in the 

sensor_config.txt file. 
- The Larus should be as far away as possible from iron parts and magnetic fields. 
- The Larus must be installed firmly and immobile. Please read the details in the 

operating manual 
- (https://github.com/larus-

breeze/doc_larus/blob/master/documentation/Larus_Bescription.pdf). 
- The Larus should be protected with a 500mA to max. 3A fuse. If it gets its voltage 

from another device, e.g. an OpenVario, this ensures that this device has sufficient 
fuse protection. 

- The GPS antennas should be mounted so that the mounting plate points downwards 
and they have visual contact upwards. They should be installed as centrally as 
possible in the instrument panel or the nose or fuselage tube and, when in flight, as 
horizontally as possible and above electrically conductive materials. 

- Their distance along the three spatial axes must be determined and entered later in 
the configuration. The more precisely you measure here, the more precisely the wind 
and your course will be correct later! 

- Please note that CFRP is also an electrically conductive material! 
- With the dual, the two GPS antennas must be at least 1m apart. 
- The master antenna (GNSS1) should, if possible, be positioned above the center of 

gravity to reduce height deviation when pulling or pushing. 
- The slave antenna (GNSS2) must be mounted at the front at the level of the 

instrument panel or further forward in the nose. 
- Lay a LAN cable from the Larus to the instrument panel and crimp a new connector 

on the cockpit side. Make sure you have the correct PIN! 
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- The RS232 socket is not IGC compliant! The PIN assignment of the socket is as 
follows: 

PIN RS232 CAN 
1 VCC (9-28V DC, internally con.) VCC (9-28V DC, internally con.) 
2 VCC (9-28V DC, internally con.) VCC (9-28V DC, internally con.) 
3 RS232_2 TX NC 
4 RS232_2 RX CAN High 
5 RS232_1 TX CAN Low 
6 RS232_1 RX NC 
7 GND (internally connected) GND (internally connected) 
8 GND (internally connected) GND (internally connected) 

 

 
 

- Uses RS232_1, Bluetooth or WiFi to connect the Larus to OpenSoar, OpenVario, 
etc. 

- For the connection with Bluetooth or WiFi, check the programming of the ESP32 
above. There you will find detailed information. 

 
 
 

VI. LEDs:  
 

- SD-CARD (blue) 
• Off: no uSD card detected 
• On: uSD card detected 
• Flashes: active logging (writing) to the card 

 
- SYSTEM (blue) 

• Off: System not working ye 
• Flashes: Indicates that FreeRTOS and the programs are running 

 
- GNSS (blue) 

• Off: No GNSS fix 
• Flashes: GNSS fix (applies to Essential and DGNSS) 

 
- ERROR (red) 
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• Flashes: at least one of the IMU, static pressure, dynamic pressure or GNSS 
sensors is not working 

• occasional flashing: DGNSS heading is missing for a short time 
 

- ESP (blue) 
• Not currently in use 

 
 
 

VII. Configuration of the Larus 
 

1. Important!! If you work with Mac or Windows, the file extensions are often not 
displayed. Look online to see how you can turn this off on your computer. It is important 
that the sensor_config.txt file has the extension txt, and the sensor.readings and 
magnetic.calibration files, if you use them, have no extension! 
It is also important that the GPS antennas have a good, clear all-round view of the sky, 
otherwise DGNSS in particular will not work! 
It takes about 1-2 minutes for DGNSS to be set up, so be patient while testing! 
Legt ins Hauptverzeichnis der SD-Karte die Konfigurationsdatei sensor_config.txt 
(https://github.com/larus-breeze/sw_sensor/tree/master/configuration). 
 

2. It must be renamed or removed after the first start of the Larus, otherwise the EEPROM 
will be overwritten every time the Larus is started. 
 

3. The most important parameters here are: 
- SensTilt_Roll = 0 (Rotation of the Larus around the longitudinal axis) 
- SensTilt_Nick = 0 (Rotation of Larus around the transverse axis) 
- SensTilt_Yaw = 0 (Rotation of Larus around the vertical axis) 
- GNSS_CONFIG = 1.0 (1.0 Essential, 2.0 Dual) 
- ANT_BASELEN = 1.0 (Distance between the front antenna and the rear antenna in 

relation to the longitudinal axis in meters) 
- ANT_SLAVE_DOWN = 0.0 (Distance front antenna to rear with respect to vertical 

axis in meters, front lower -> value positive) 
- ANT_SLAVE_RIGHT = 0.0 (Distance from front antenna to rear with respect to 

transverse axis in meters, front further to the right -> value positive) 
 

4. How to use the file exactly is described in the Larus operating manual 
https://github.com/larus-breeze/doc_larus/blob/master/documentation/Larus_Beschreibung.pdf). 
 

5. Place the empty text file, without the txt ending, sensor.readings in the main directory 
of the SD card so that you can check under NMEA ports in the monitor whether 
everything is working and what your values are. 
 

6. If you want to carry out a magnetic calibration on the ground, create the empty text file, 
without the ending txt, magnetic.calibration in the main directory of the SD card. This 
is generally not recommended. 
 

7. Create a logger folder if you want to record the logging of the measured values at 100Hz. 
 

8. Create a magnetic folder if you want to turn on logging of magnetic calibration events. 
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9. Some of these events should occur during the calibration process. If you frequently 
observe other events, there are probably moving ferromagnetic parts near the 
magnetometer. 

 
10. If you want to reset the Larus to its factory defaults, download the sensor_config.txt file 

here, save it to the SD card and restart your Larus. 
https://github.com/larus-breeze/sw_sensor/tree/master/configuration 
 

11. Then remove the file from the SD card again. 
 
 
 

VIII. Important settings in OpenSoar 
 

1. In the wind settings, switch external wind on, ZigZag off and circling on, otherwise the 
external wind is not used. 
 

2. It is recommended to set the IGC logger (e.g. Flarm) as Device A and Larus as Device 
B, because then the height of the logger is displayed in OpenSoar, which is particularly 
recommended for competitions. 
 

3. If no external vario is used, the vario sound can be switched on and adjusted under 
System -> Displays -> Audio vario. 
 

4. The blue wind arrow on the screen shows the 30s averaged wind and the green one 
shows the real wind. 
 

5. If the artificial horizon in OpenSoar does not match the actual position of the aircraft, 
then lines 01 - 03 must be adjusted in sensor_config.txt. 

 
To connect the Larus to OpenSoar via RS232: 

1. Make sure that the cable is assigned correctly, 1:1, where you use RS232_1 and 
RS232_2 is not assigned. 
 

2. In the NMEA menu, select the ttyS port, the baud rate 38400 and Larus as the driver. 
 

To connect the Larus to OpenSoar via Bluetooth: 
1. Pair your device's Bluetooth with the Larus by selecting "Larus" in the Bluetooth menu. 

 
2. In the NMEA menu, select the Larus connection and the Larus driver. 

 
To connect the Larus to OpenSoar via WiFi: 

1. Connect your devices to the Larus by selecting the WiFi network “Larus” and entering 
“LarusSensor” as the password. 
 

2. In OpenSoar, select the following under NMEA connection:Anschluss: TCP-Client 
- IP Address: 192.168.4.1 
- Port: 8880 
- Driver: Larus 
- Comparison with the device: Yes 

 


